• Login:

Welcome to the XBMC HUB FORUMS.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed.

UPDATE YOUR SPORTSDEVIL ADDON!

Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Senior Member
    Join Date
    May 2012
    Posts
    543
    Thanks
    10
    Thanked 1 Time in 1 Post

    my Optimal Ouya Settings

    Hi guys,
    I've been playing with the ouya's for awhile now and have had the problem that a few people encountered with stuttering through ethernet or the funny machine gun like sounds that would crop up every now and then. some people have said the stuttering starts 10 minutes in or 20 minutes in or half way through a movie etc. eventually the movie or video would freeze up. I seemed to experience all these symptoms at one time or another. at first i thought it was maybe a running out of memory or cache issue but I always saw quite a bit of buffer built up ahead of the stream, so i knew my streaming speed was OK. I've done alot of reading and the info i've found has been few and far between but I did find a couple things that seem to have helped clean up this issue for me. my ouya's now seem to run flawless with everything I've thrown at them. and I did some testing on files that would stutter, then change settings and see the results. changing the settings below made all the difference for me.
    just want to share what i've found in hoping it helps others if there experiencing the same problems. thxs goes to those that have posted these settings in different threads that seemed to help for them. (tuxen being one of them)

    should start by mentioning I'm running the second to last ouya store xbmc version... the one that doesn't have ac3 or dts disabled....

    1) I was using cachemembuffer = 0 advanced settings. I found that changing over to tuxens advanced settings xml (xbmchub maintenance, tweaks) seemed to work better. it still showed buffer building ahead but wouldn't build up as far ahead as the 0 setting xml... it's been mentioned by some that running any cachemembuffer size may not be necessary. I can't argue but tuxens version seems to be doing well for me so I'm going to stick to it for now.

    2) under settings, video, file lists, I disabled the setting "extract thumbnails and video information"

    3)under settings, video, playback

    render method auto detect
    allow hardware acceleration enabled
    adjust display refresh rate to match video off (disabled)
    pause during refresh off (disabled)
    rate change off
    synch playback to display enabled
    a/v synch method video clock (resample audio)
    allowed error in aspect ratio to minimize black bars none
    display 4:3 video as normal
    activate teletext disabled (not sure if this makes a difference)
    scale teletext to 4:3 disabled (not sure if this makes a difference)

    some people also disable rss feeds in settings appearance, I believe. but I found this doesn't make a difference for me and I prefer to leave that setting enabled as it's a quick visual way to see that you are connected to the internet when starting up....

    you can also go into the ouya section, advanced, apps, xbmc, and scroll down and click clear cache....

    with these settings I am getting video's that were previously stuttering to play butter smooth with no stuttering or machine gun like sounds through playing multiple movies in succession as long as the bitrate of the video isn't so much that streaming can't keep up.

    hope this might help some peeps,
    gotta say these ouya's kick ass!
    have a good one,
    bigdogeh.
    Last edited by bigdogeh; 11-06-2013 at 01:27 PM.

  2. #2
    Team XBMC HUB Helper
    Join Date
    May 2012
    Location
    Toronto, Canada
    Posts
    1,330
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for sharing your findings. Hopeful this will give others options to try out.

  3. #3
    Team XBMCHUB.COM Moderator
    Join Date
    Mar 2012
    Location
    Denmark
    Posts
    4,082
    Thanks
    0
    Thanked 22 Times in 13 Posts
    Hi thanks.
    One thing "adjust display refresh rate to match video on start stop" does not work on android since it has a locked refresh rate at 60HZ no movie at 24p or 50HZ can make the display change to these refresh rates. :-/ one of my biggest wishes is that it could.

    You have to use the oppersite setting: "synch playback to display enabled" which I see you do to but the above setting sadly won't do a thing.
    Last edited by tuxen; 11-02-2013 at 06:02 AM.
    | ..my middle name is edit ..not english | read this first | search |
    -
    CLICK TO DONATE - help me save up for the next beer.
    my help and knowledge gained from it will go directly back into our community.

  4. #4
    Junior Member
    Join Date
    Oct 2013
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Unfortunately the stutter persists with live streaming for me, but I really appreciate you taking the time to post this, bigdogeh!

  5. #5
    Junior Member
    Join Date
    Nov 2013
    Posts
    11
    Thanks
    0
    Thanked 0 Times in 0 Posts

    settings

    Quote Originally Posted by bigdogeh View Post
    Hi guys,
    1) I was using cachemembuffer = 0 advanced settings. I found that changing over to tuxens advanced settings xml (xbmchub maintenance, tweaks) seemed to work better. it still showed buffer building ahead but wouldn't build up as far ahead as the 0 setting xml... it's been mentioned by some that running any cachemembuffer size may not be necessary. I can't argue but tuxens version seems to be doing well for me so I'm going to stick to it for now.

    2) under settings, video, file lists, I disabled the setting "extract thumbnails and video information"

    3)under settings, video, playback

    render method auto detect
    allow hardware acceleration enabled
    adjust display refresh rate to match video on start stop
    pause during refresh
    rate change off
    synch playback to display enabled
    a/v synch method video clock (resample audio)
    allowed error in aspect ratio to minimize black bars none
    display 4:3 video as normal
    activate teletext disabled (not sure if this makes a difference)
    scale teletext to 4:3 disabled (not sure if this makes a difference)

    some people also disable rss feeds in settings appearance, I believe. but I found this doesn't make a difference for me and I prefer to leave that setting enabled as it's a quick visual way to see that you are connected to the internet when starting up....

    you can also go into the ouya section, advanced, apps, xbmc, and scroll down and click clear cache....

    with these settings I am getting video's that were previously stuttering to play butter smooth with no stuttering or machine gun like sounds through playing multiple movies in succession as long as the bitrate of the video isn't so much that streaming can't keep up.
    tried this... i'm NOT getting stuttering but Pausing to buffer streaming videos. still happens.

    usually it takes a few mins to buffer some video from the start, then it can play fine for 10 to 30mins, then pauses again and rebuffers for a few more mins. very annoying and don't have the option to run a line vs using wifi. when my wifi is fine on other devices.

    unsure if its just junky Ouya WiFi or what? becuase WiFi streaming works perfect on my Laptop + ipad.
    tried to reset the router/modem, disable all other wifi devices etc, still no.

    going to try other setting or sideload and test my friends Ouya here next week.

  6. #6
    Member
    Join Date
    Oct 2013
    Posts
    78
    Thanks
    0
    Thanked 0 Times in 0 Posts

    my Optimal Ouya Settings

    It may be your stream source. Test your streaming with some high bandwidth source first. I use REVISION3 to test video playback as they are fast and not overwhelmed by users.

  7. #7
    Junior Member
    Join Date
    Jan 2013
    Posts
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts
    For me no matter what I try stutter still persists. Unlike others my stuttering kicks in after around 90 minutes. This didn't used to happen so IDK why it started. My OUYA gets warm and I did suspect it was heat related but stutter can be stopped by stopping the film going out to menu then resuming the film even if you do this immediately. As far as overheating goes I did find lying my OUYA on it's side made it run cooler so I completely discarded the problem being temperature related. After backing the OUYA and championing it's cause it's got to the point where I hate mine. Development of firmware is now at the point where no issues are being addressed and as far as a it goes for being a cheap media player (XBMC specifically) it's just not cutting it. If the long term plan was to release a new one (OUYA) every year then they may as well not bother because I can't see me buying a next gen unit. At 100 I'm not devastated, but as a rule I am a loyal consumer. If I like a brand I'll generally stick with it.

  8. #8
    Junior Member
    Join Date
    Oct 2013
    Posts
    20
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by danxbmc View Post
    For me no matter what I try stutter still persists. Unlike others my stuttering kicks in after around 90 minutes. This didn't used to happen so IDK why it started. My OUYA gets warm and I did suspect it was heat related but stutter can be stopped by stopping the film going out to menu then resuming the film even if you do this immediately. As far as overheating goes I did find lying my OUYA on it's side made it run cooler so I completely discarded the problem being temperature related. After backing the OUYA and championing it's cause it's got to the point where I hate mine. Development of firmware is now at the point where no issues are being addressed and as far as a it goes for being a cheap media player (XBMC specifically) it's just not cutting it. If the long term plan was to release a new one (OUYA) every year then they may as well not bother because I can't see me buying a next gen unit. At 100 I'm not devastated, but as a rule I am a loyal consumer. If I like a brand I'll generally stick with it.
    Agree completely. I've already begun looking for other options, since I do like xbmc, but the ouya itself has been a major disappointment. I've tried every fix I came across and the stuttering persists on live streams for me.

    I might try to sell it. Only problem is I'm not the only one in this town trying to do so.

  9. #9
    Team XBMCHUB.COM Moderator
    Join Date
    Mar 2012
    Location
    Denmark
    Posts
    4,082
    Thanks
    0
    Thanked 22 Times in 13 Posts
    Could the stutter might be objective? As I can see a lot of stutter compared to my RPi I'm a videophile though. And for someone who isn't or might be used to this stutter that I'm talking about (nothing that makes it directly unwatchable but is for me damn annoying) don't notice it because they are used to it and don't even see it?

    As for me the biggest revelations came went I had the two devices side by side or went from Ouya to RPi.
    Just a thought?
    Last edited by tuxen; 11-06-2013 at 06:04 AM.
    | ..my middle name is edit ..not english | read this first | search |
    -
    CLICK TO DONATE - help me save up for the next beer.
    my help and knowledge gained from it will go directly back into our community.

  10. #10
    Team XBMCHUB.COM Moderator
    Join Date
    Mar 2012
    Location
    Denmark
    Posts
    4,082
    Thanks
    0
    Thanked 22 Times in 13 Posts
    For me no matter what I try stutter still persists. Unlike others my stuttering kicks in after around 90 minutes. This didn't used to happen so IDK why it started. My OUYA gets warm and I did suspect it was heat related but stutter can be stopped by stopping the film going out to menu then resuming the film even if you do this immediately. As far as overheating goes I did find lying my OUYA on it's side made it run cooler so I completely discarded the problem being temperature related. After backing the OUYA and championing it's cause it's got to the point where I hate mine. Development of firmware is now at the point where no issues are being addressed and as far as a it goes for being a cheap media player (XBMC specifically) it's just not cutting it. If the long term plan was to release a new one (OUYA) every year then they may as well not bother because I can't see me buying a next gen unit. At 100 I'm not devastated, but as a rule I am a loyal consumer. If I like a brand I'll generally stick with it.
    I experienced the (real bad) stutter after watching half a long movie or livestreams to..
    Really odd. Stop and play fixes it. And I'm more than sure it has nothing to do with temperatures.

    Agree with the awesome hardware but terrible execution and non existent support from Ouya side. Not obtaining licenses for tegra to support AC3/DTS or an option for mpeg2/vc1 hardware decoding together with promised CEC that we have not heard about since before launch, is below stupid. It doesn't make it better that they won't release any sales numbers.

    But give it a chance hopefully someone if not team XBMC can step up and do something about this. The most annoying thing is that its so closed that things such as openELEC would never come into consideration.

    REMEMBER:
    Afterall we are running alpha's and frodo a with back ports to get it working. Gotham will be the first stable android version so there's quite some development and hope to go with.

    Play around with the emulators/side loading hacks/games until the XBMC situation hopefully has matured for the better. Only time will tell.
    Last edited by tuxen; 11-06-2013 at 06:25 AM.
    | ..my middle name is edit ..not english | read this first | search |
    -
    CLICK TO DONATE - help me save up for the next beer.
    my help and knowledge gained from it will go directly back into our community.

 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •